[USACO10OCT] Lake Counting S

[USACO10OCT] Lake Counting S

题面翻译

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个 N × M ( 1 ≤ N ≤ 100 , 1 ≤ M ≤ 100 ) N\times M(1\leq N\leq 100, 1\leq M\leq 100) N×M(1N100,1M100) 的网格图表示。每个网格中有水(W) 或是旱地(.)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入第 1 1 1 行:两个空格隔开的整数: N N N M M M

2 2 2 行到第 N + 1 N+1 N+1 行:每行 M M M 个字符,每个字符是 W.,它们表示网格图中的一排。字符之间没有空格。

输出一行,表示水坑的数量。

题目描述

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.

输入格式

Line 1: Two space-separated integers: N and M * Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

输出格式

Line 1: The number of ponds in Farmer John’s field.

样例 #1

样例输入 #1

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出 #1

3

提示

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>


using namespace std;
typedef pair<int, int> PII;


const int N = 110;
char g[N][N];
bool st[N][N];
int res;

int n, m;
    
int dx[] = {
   1,1,1,0,0,-1,-1,-1};
int dy[] = {
   1,0,-1,1,-1,1,0,-1};

queue<PII> q;

void bfs(int x, int y){
   
    q.push({
   x, y});
    
    while(q.size() > 0){
   
        
        auto t = q.front();
        q.pop();
        
        for (int i = 0; i < 8; i ++){
   
            int a = t.first + dx[i];
            int b = t.second + dy[i];
            
            if (a < 0 || a >= n || b < 0 || b >= m) continue; // 越界
            if (st[a][b]) continue; // 已经走过
            if (g[a][b] != 'W') continue; // 不是水坑
            
            st[a][b] = true;
            q.push({
   a, b});
        }    
    }
 
}


void dfs(int x, int y){
   
    for (int i = 0; i < 8; i ++){
   
        int a = x + dx[i];
        int b = y + dy[i];
        
        if (a < 0 || a >= n || b < 0 || b >= m) continue; // 越界
        if (st[a][b]) continue; // 已经走过
        if (g[a][b] != 'W') continue; // 不是水坑
        
        st[a][b] = true;
        dfs(a, b);
    }    
}

int main(){
   
    scanf("%d%d", &n, &m);
    
    for (int i = 0; i < n; i ++){
   
        scanf("%s", g[i]);
    }
    
    for (int i = 0; i < n; i ++){
   
        for(int j = 0; j < m; j ++){
   
            if (g[i][j] == 'W' && !st[i][j]){
   
                st[i][j] = true;
                // dfs(i, j);
                bfs(i, j);
                res ++;
            }
        }
    }
    
    printf("%d\n", res);
    
    return 0;
}

相关推荐

  1. [USACO10OCT] Lake Counting S

    2023-12-22 21:56:04       60 阅读
  2. [USACO18DEC] S 补题报告

    2023-12-22 21:56:04       37 阅读
  3. [USACO18JAN] Cow at Large P

    2023-12-22 21:56:04       23 阅读
  4. 洛谷P2176 [USACO11DEC] RoadBlock S / [USACO14FEB]Roadblock G/S

    2023-12-22 21:56:04       31 阅读
  5. P1596 [USACO10OCT] Lake Counting S 题解

    2023-12-22 21:56:04       35 阅读
  6. P1697 [USACO18JAN] Lifeguards B 题解

    2023-12-22 21:56:04       47 阅读

最近更新

  1. docker php8.1+nginx base 镜像 dockerfile 配置

    2023-12-22 21:56:04       94 阅读
  2. Could not load dynamic library ‘cudart64_100.dll‘

    2023-12-22 21:56:04       101 阅读
  3. 在Django里面运行非项目文件

    2023-12-22 21:56:04       82 阅读
  4. Python语言-面向对象

    2023-12-22 21:56:04       91 阅读

热门阅读

  1. 1022 D进制的A+B Python——“优雅,实在太优雅了”

    2023-12-22 21:56:04       59 阅读
  2. 基于MATLAB的鹰群优化算法求解单目标优化问题

    2023-12-22 21:56:04       64 阅读
  3. LeetCode-146.LRU缓存(Python)

    2023-12-22 21:56:04       68 阅读
  4. 面试-旋转数组的三种方法

    2023-12-22 21:56:04       56 阅读
  5. Springboot日常开发使用策略、工厂模式

    2023-12-22 21:56:04       65 阅读
  6. 使用灰狼算法优化的LSTM实现数据回归预测

    2023-12-22 21:56:04       58 阅读
  7. OpenVAS 数据库管理

    2023-12-22 21:56:04       52 阅读